Universal-Box - Apollo GraphQL Server Template Initialization Failure – Incident details

All systems operational

Apollo GraphQL Server Template Initialization Failure

Resolved
Partial outage
Started 2 months agoLasted 2 days

Affected

Package

Partial outage from 12:35 PM to 12:35 PM, Degraded performance from 12:35 PM to 12:35 PM

Updates
  • Resolved
    Resolved

    Upon investigation, it was determined that the issue stemmed from a recent update to the Universal-Box package that inadvertently removed critical dependencies required for the Apollo GraphQL Server template. This update also altered the project structure, causing the sample data models to fail during initialization.

    This incident has been resolved.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    The incident impacted users who attempted to scaffold new projects using the affected template. Users reported the following issues:

    • The initialization process failed with an error message indicating missing dependencies.

    • Sample data models were not generated as expected, leading to confusion and delays in project setup.

    • Users were unable to access the GraphQL Playground due to server configuration issues.


      We are continuing to work on a fix for this incident.